Back to overview
Resolved
Scheduled Maintenance – Brief Dashboard Downtime
Jul 11, 2026 at 11:26am UTC
Affected services
Singapore Node from (nube.sh)
Resolved
Jul 11, 2026 at 11:26am UTC
Incident Time: July 10, 2026 (GMT+5)
The dashboard was temporarily unavailable for approximately 1 minute due to scheduled maintenance on our infrastructure.
The maintenance was completed successfully, and all services were restored immediately afterward.
Current Status: Resolved. All services are operating normally.
Affected services